Catapult Mau Doesn't work..?

Discussion in 'Bug Reports' started by Vanitas91, Jun 29, 2021.

  1. Vanitas91

    Vanitas91 New Member

    Joined:
    Jan 21, 2017
    Messages:
    1
    Likes Received:
    0
    Came back to RFO today after a long time off after getting a nostalgia rush. Started leveling a Bell Driver, only to get into a Catapult(or Ballista) Mau, try to go attack some mobs and nothing is happening. The animation will play but no damage, doesn't even aggro them. Is this a serious bug or something I missed? Im on the Pegasus server, and I the Goliath Mau works fine.
    This is a huge bummer as the cata was one of my favorites, as it does a ton more dps. Thanks for any info on this.
    EDIT: nevermind I guess...? I logged out and back in, and tried again. For some reason the ammo I had dissapeared, so I bought more and it suddenly worked. IDK what the hell kind a bug this is, but Im glad its working now I suppose. Thanks for the quick responses guys :D
     
    Last edited: Jun 29, 2021
  2. lollypop

    lollypop Member

    Joined:
    Mar 31, 2016
    Messages:
    87
    Likes Received:
    33
    You're welcome. Please mark this post solved.
     

Share This Page